Questions En > Help requests

Error message on remaster install

(1/3) > >>

I was just wondering if anyone has come across this error message when trying to install a remastered version of Ubuntu. 

The pic above shows VBox but I am also having the problem on hard drive.  Currently I am using Pinguy Builder, a fork of the now defunct Remastersys, to build a live ISO of a couple of remixes I am doing of Bento.  The error shows up at some point of the installation - it is all a bit random as to when it will strike.  I have tried using Startup Disk Creator, unetbootin and dd in terminal.  Sometimes one fails to launch the installer, but another will get past that point.  From what I have gleaned online the error message itself is a bit generic - it can mean anything from a failing hard drive to "sorry, we have run out of coffee!!".  I have tried three different hard drives - same result.  I don't have a problem with an ISO dropped straight off the net, but remaster it a couple of times on a hard drive and the error starts to pop up.  It's a bit frustrating, as it wasn't that many years ago that remastering a spin with something like Remastersys was like falling off a log!   

I haven't. As you are working with Virtualbox, it might be something related to the type of virtual image you created, or perhaps some kind of option that would be needed : really I confess I don't know.

If it would be on bare metal, we might look for some inconsistencies in the file system… or some issue with the hard drive. Wondering : have you tried to install and ticked the options meant to update while installing or so? I usually only tick the mp3 non free option, not the rest, to avoid filling the virtual memory. You tell?

Hi Mélodie,

The problem first arose when I installed a remaster from VBox on to a hard drive.  Eventually I installed a clean Bento to the hard drive and did the all the modifications from scratch.  The problem occurred again with install problems with the remasters.  I have tried three different hard drives, and I don't tick any update options when installing as the new system is already up to date.  I haven't tried Bodhibuilder yet - maybe that might work.  These are all forks of the old Remastersys - maybe inconsistencies are starting to accumulate.  What are you using to create an ISO?   

I use Customizer. I have been using it for years now, and after a while I threw away the gui and used only the console. Soo easy, and so much lighter. Also I use a ssh connection to a remote server to do that, which really eases the whole process.

you can start easily if you follow the startup guidelines,

have fun!  :P

Hi Mélodie,

I have taken your suggestion and am trying out Customizer.  I have looked through the documentation and have downloaded it and its dependencies - all except isolinux.  I can't seem to find that anywhere.  I have on the system syslinux, extlinux, but no isolinux.  A search via apt-cache/Synaptic comes up with bootcd, and xorriso which is installed.  When using the install instructions apt-get returns this -

--- Code: ---apt-get install git build-essential fakeroot make binutils g++ \
python python-dev python-qt4 pyqt4-dev-tools squashfs-tools \
xorriso x11-xserver-utils xserver-xephyr qemu-kvm dpkg-dev \
debhelper qt4-dev-tools qt4-linguist-tools isolinux \
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package isolinux
--- Fin du code ---

Everything else installed.  Then on installation of Customizer this -

--- Code: --- cd .. && sudo dpkg --install customizer*.deb
Selecting previously unselected package customizer.
(Reading database ... 293500 files and directories currently installed.)
Preparing to unpack customizer_4.1.5-0+20170208_all.deb ...
Unpacking customizer (4.1.5-0+20170208) ...
dpkg: dependency problems prevent configuration of customizer:
 customizer depends on isolinux; however:
  Package isolinux is not installed.

dpkg: error processing package customizer (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu (2.1.46ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:

--- Fin du code ---

I am running an updated Bento 14.04 64bit.  A fair amount of internet searching hasn't thrown up any answers - any ideas?

EDIT - I think I might have worked it out.  I installed instead via the "make install" option found here.  Now to work out how to use it!

EXTRA EDIT - Wow, easy to use.  I tried a quick hack of your Bento.  I like the way Xephyr kicks in when you hit Desktop - really cool - you can trouble-shoot on the run.  However I seem to be back to the original issue, maybe (!) - 

--- Code: ---xorriso : UPDATE : 105 files added in 1 seconds
xorriso : FAILURE : Given path does not exist on disk: -boot_image system_area='/usr/lib/ISOLINUX/isohdpfx.bin'
xorriso : UPDATE : 105 files added in 1 seconds
xorriso : aborting : -abort_on 'FAILURE' encountered 'FAILURE'
--- Fin du code ---


[0] Index des messages

[#] Page suivante

Utiliser la version classique