Questions En > Help requests

Error message on remaster install

<< < (3/3)

Hi, if you want to use "dd" to create your bootable USB devices you need to have isohybrid in the machine installed where you remaster and use a script after building to make a few changes on the ISO created by Customizer. Here is one of them, for an example:

(You get all my little tricks he he!  ;-) )

/Scripts that I orgininally didn't even make myself… But I use them, and tweak them as time goes.

--- Code: ---#!/bin/sh



mv /home/Ubuntu-$ARCH-$VERSION.iso $ISONAME
chmod a-x $ISONAME
isohybrid $ISONAME
md5sum $ISONAME > $ISONAME.md5sum
chown $USER:$GROUP $ISONAME.md5sum

--- Fin du code ---

arguments are in high cases, $XYZY stands for the value you insert after the sign '=' which comes after the argument.

the line "mv /home/Ubuntu-$ARCH-$VERSION.iso $ISONAME"  will have to be tweaked as maybe now the default is having the work directory under "/home/customizer" and no more under "/home" as it used to be, unless you changed that part to something else, then adapt it accordingly.

If you have questions about the rest of the script, please send! (users and groups are different on the remote server on which I build than locally, etc.)

Yes, I still have my x220. I had broken the motherboard, but I bought another one on ebay and I changed it. I don't like the way the keyboard behaves, it feels very jerky, (I type with 10 fingers fast enough) and I don't see any way around, unless I plugin an external keyboard. Is the one you have jerkey? If you know about a solution I'd like to have it. :)

PS: isohybrid belongs to the syslinux package, which is probably installed in your system.

Hi Mélodie,

I'll give that script a run in the next few days - I've tweaked the work directory line.  I only use the X220 when doing maintenance but I don't recall any issues with the keyboard - seemed all normal to me.  Maybe you need to define "jerky".  What I can't stand about laptops is the scroll pad though - I have to connect a mouse!

I had to install isolinux from a 16.04 repo.  Did you get yours from a 14.04 repo or some other place?

EDIT - decided not to wait and tried the script!  Worked out to run as su.  Neat!  Moves the ISO out of the work directory, which allows Customizer to rebuild if needed.  I'll have to dd and boot to see what the result is.

Hi Taco.22,

I checked, and indeed no isolinux in Trusty. To get it, you might want to upgrade to Xenial. In Trusty, I still use an older version of Customizer:

and it is xorriso which comes out when searching for isolinux (ad bootcd, but xorriso was already in the list of packages to install before compiling customizer):

--- Code: ---$ apt-cache search isolinux
xorriso - outil de manipulation ISO-9660 et Rock Ridge en ligne de commande
bootcd - Lance votre système à partir d'un CD sans avoir besoin de disques
--- Fin du code ---

(Tried "LANG=C" to output it in English, but it didn't work in that remote system)

You seem to have found a way to make it work in 14.04 with the latest customizer version, so I think it's ok and you don't need to change?


[0] Index des messages

[*] Page précédente

Utiliser la version classique