Auteur Sujet: Networking - wicd and gigolo  (Lu 5164 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1744
    • Citrotux
Re : Re : Networking - wicd and gigolo
« Réponse #15 le: 22 janvier 2013 à 01:28:26 »
Installed libdbus-1-dev but got same message minus the lines pertaining to Package dbus ...

What about:
libgtk2.0-dev

?

Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #16 le: 22 janvier 2013 à 02:08:06 »
Wow, thats 76mb installed!  That would mean over 130mb extra in the system just to autostart gigolo and to duplicate some entries already in the right-click menu.  Too much.

Time to think outside the square.  Why won't gigolo autostart?  I have tried .desktop in /etc/xdg/autostart, all sorts of other ideas, every known config in ~/openbox/autostart - nothing.  Regardless of settings htop doesn't show it listed.  Start it from menu and bingo - there it is in htop.

I then had a look in /usr/bin and found "gigolo" is a "shared library".  I'm doing some basic research but what makes a shared library different to an executable?  Just out of curiosity epdfview is also a shared library and also won't autostart.   Actually, I can't get ANY application to autostart.  Just tried sakura, and then geany.  I could be barking up a wrong tree here.  What am I missing?

Oh, and is it possible to get mimas's xdg-autostart only that he mentioned on the old forum.

EDIT - this seems to have become a bigger issue.  I just tried setting up a script but it failed to autostart.  I think the question now is - why won't Village_RC autostart applications?  Maybe a new thread is needed.

« Modifié: 22 janvier 2013 à 02:26:23 par Taco.22 »
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1744
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #17 le: 22 janvier 2013 à 02:41:20 »
Hi,
You need dev packages to be able to build anything;

You can avoid part of the recommends by setting it to "false" in the 99synaptic file in /etc/apt/apt.conf.d ;

you can even get rid of all the devel packages : I compiled successfully in Debian wheezy and did a tarball;

you can get it  : http://meets.free.fr/debian/obsession-compiled-for-debian-testing.tar.xz

Enjoy!

(I will have a look tomorrow in my Debian testing install to see if I can make it work the way I do in Archlinux).

Good leaders being scarce, following yourself is allowed.