Auteur Sujet: [Parole] Xubuntu 14.04 does not play wma  (Lu 2462 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1689
    • Citrotux
[Parole] Xubuntu 14.04 does not play wma
« le: 19 juillet 2014 à 14:55:49 »
Hi there!

In Xubuntu 14.04 if you use Evolution and receive your phone messages by mail, you might not be able to get the messages while doing a simple clic on the play button. Why that? This is because the mime type (wav with some of the providers) is by default associated with Parole which does not find the right gstreamer able to read an audio file. To illustrate what happens when a wma file is opened with Parole, here is a screen shot


and here is a list of gstreamer codecs I will add before trying again:
Citer
bluez-gstreamer
gir1.2-gstreamer-0.10
gstreamer0.10-alsa
gstreamer0.10-ffmpeg
gstreamer0.10-gnomevfs
gstreamer0.10-nice
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-base
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly
gstreamer0.10-pulseaudio
gstreamer0.10-tools
gstreamer0.10-x
libgstreamer-plugins-bad0.10-0
libgstreamer-plugins-base0.10-0
libgstreamer0.10-0


There also exist a specific package, xubuntu-restricted-extras or such, I'll compare to see what it pulls in and retry. To do that, I would like to use Synaptic, so I install it from within the Ubuntu Software Center and from there I meet with more issues:

Ubuntu Software Center isn't available from the System menu in the whisker-menu-plugin, so I suppose there must be a glitch in the desktop file which provides the menu, but unfortunately I don't have time to check all the issues I meet with in each edition I test and try to use. So I will just report it as is showing this one post to some people at the Xubuntu chan.

Next, I seek for Ubuntu Software Center in the search field, and find it, launch it, and install Synaptic (I could have used the Terminal too obviously, more simple, but I want to experiment the "gui tools only" way.

Now Synaptic is installed, and it even shows in the System menu. But it won't start : once, twice, nothing happens. From within a console, typing "synaptic-pkexec" triggers an an error message about XDG_RUNTIME_DIR not set in the environment.


Again, I can start Synaptic from the console with gksudo, or just change the Exec=synaptic-pkexec line to "Exec=gksu -S synaptic" in the desktop file. I can do that, and I'll save the file to /home/user/.local/share/applications (and create the share/applications subdirectories). The -S switch for gksu forces gksu to use the sudo way, and prompt for the relevant password, while the -w forces it to use the su option (prompting then for the root password).

Synaptic allows using filters on names and helps gather all the packages needed in the same view, so I hope after this I can start Synaptic and install the gstreamer packages easily.

Well I can't, unless I install gksu. Indeed, pkexec having replaced it, gksu isn't installed! Too bad that pkexec does not work here! So I need to install gksu anyway. :o)

Another option to solve the issue could be to install audacious and it's plugins, which are presented as being able to read may formats. Else, Audacious is nice and light, and can also read streams.


The only thing left to do is to check for audacious to be the default application for the mime types related to audio, in the mime type association section of the preferences.
For this purpose, access to the "all parameters" button in the Whisker-menu:


Then hit the Mime type editor in the System section, and check the wma, ogg and any type of file extension name for audio you can think about, to see if the application associated with it is what you want:



Here gmusicbrowser is the default application for wav files:


Why does Xubuntu deliver it's Edition with Gmusicplayer and Parole, and not with some programs which can work out of the box?

The question is opened.

Good leaders being scarce, following yourself is allowed.

Hors ligne Desmoric

  • Modérateur Global
  • Membre Junior
  • *****
  • Messages: 56
Re : [Parole] Xubuntu 14.04 does not play wma
« Réponse #1 le: 24 août 2014 à 21:55:48 »
Install w32codecs. it would be run in every multimedia player.

Did you try with VLC without this codecs ?
« Modifié: 24 août 2014 à 21:58:07 par Desmoric »
Partager c'est s'enrichir mutuellement
Hackeur vaillant, rien d'impossible

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1689
    • Citrotux
Re : Re : [Parole] Xubuntu 14.04 does not play wma
« Réponse #2 le: 25 août 2014 à 23:18:48 »
Install w32codecs. it would be run in every multimedia player.

Did you try with VLC without this codecs ?

Hello there!

In fact there is a bug in humm not Evolution but in WebkitGTK. It has been narrowed after I had a chat with one of the developers of Evolution. This is a bug report where we had a talk with one of the devs of WebkitGTK, and where there is still something left to do for me. (After school vacation is over, I think I might be able to take some time to continue using the instructions which have been provided to me).

You can have a look here if you want to:
https://bugs.webkit.org/show_bug.cgi?id=135292

Anyway what is above might also be useful for anyone who wants to know how to tweak the file association with the mime type. Which codecs do you find in a win32codecs package?

Good leaders being scarce, following yourself is allowed.

Hors ligne Desmoric

  • Modérateur Global
  • Membre Junior
  • *****
  • Messages: 56
Re : Re : Re : [Parole] Xubuntu 14.04 does not play wma
« Réponse #3 le: 26 août 2014 à 20:49:11 »
Which codecs do you find in a win32codecs package?

This ones : http://doc.ubuntu-fr.org/w32codecs
Partager c'est s'enrichir mutuellement
Hackeur vaillant, rien d'impossible