Auteur Sujet: [Debian 7.0] fresh install with poor man install method  (Lu 2583 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1675
    • Citrotux
[Debian 7.0] fresh install with poor man install method
« le: 19 août 2013 à 14:27:29 »
I wanted to update Scorpio RC4, (formerly installed to a Dell tower, Pentium IV with 1 GB ram) which I did, then realized I had half of the update using Jessie/SID. How did I achieve this? I guess I have been too fast reconfiguring the sources.list.

Anyhow unsure of how to do things next I erased the install and reinstalled anew from a Lxde ISO image taken from here:
http://cdimage.debian.org/debian-cd/7.1.0/i386/iso-cd/

( this iso debian-7.1.0-i386-lxde-CD-1.iso)

I wanted to start from USB with my usual mount to loop method, but it appeared the ISO is not fit for this method, so after several tries I ended up downloading vmlinuz and initrd.gz from here:
http://http.us.debian.org/debian/dists/stable/main/installer-i386/current/images/hd-media

and installed with the poor man install method as presented here:
http://www.debian.org/releases/stable/i386/ch04s04.html.fr

and prepared a boot from Grub2 almost as presented here:
http://www.debian.org/releases/stable/i386/ch05s01.html.fr#boot-initrd

just I didn't edit /boot/grub/grub.cfg but the file /etc/grub.d/40_custom which is meant for custom entries, and once done I invoked as root "update-grub2".

It appeared that I should have added the option desktop=lxde somewhere in the boot stanza:
menuentry 'New Install' {
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
linux /boot/newinstall/vmlinuz
initrd /boot/newinstall/initrd.gz
}

because instead of ending with LXDE I ended with… Gnome3 ! Which I didn't like, so I had to work some more time after the install to correct this.

I wonder if the grub2 text block allows adding options to the linux command line?

The said option can be found in the ISO image under isolinux, in the txt.cfg file:
default install
label install
menu label ^Install
menu default
kernel /install.386/vmlinuz
append desktop=lxde vga=788 initrd=/install.386/initrd.gz -- quiet


The post install steps have been, installing Lxde because I wanted to escape Gnome 3 as fast as possible, (just Lxde core, because "task lxde" or such installs a world of programs I wouldn't need) then login to Lxde, remove all possible Gnome components and trying not to break the system while doing so, then install the additional packages and configuration which I keep at http://meets.free.fr/Downloads, in directories which are now more and more structured to find easily all the setups and changes done previously in the different Ubuntu Openbox spins. (It's a work in progress).

After that I just had to logout, change the session to "Openbox", and also reconfigure .xinitrc because I had 3 dbus-daemon started and 4 sessions! ^^

The LXDE main components are gone, the icons are Faenza with Faenza Mint on the top, providing a nice green set of icons.

There is one issue left: the fonts are ugly, and this will be some work to make them look smooth as they usually are in a Lubuntu, a Xubuntu (and I would suppose in the official Ubuntu as well, which I very seldom boot so I don't quite remember).

Fonts! How to make them look consistent with the right thickness and smoothing? I started working on it, and I plan to read again the archlinux wiki howto on this one, for it has helped before. My fear is I think the components needed might not be available in the Debian current repositories.

To be followed…

« Modifié: 19 août 2013 à 14:35:07 par mélodie »
Good leaders being scarce, following yourself is allowed.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : [Debian 7.0] fresh install with poor man install method
« Réponse #1 le: 19 août 2013 à 21:00:15 »

Fonts! How to make them look consistent with the right thickness and smoothing? I started working on it, and I plan to read again the archlinux wiki howto on this one, for it has helped before. My fear is I think the components needed might not be available in the Debian current repositories.



gtk-theme-name="StoneWashed"
gtk-icon-theme-name="gnome"
gtk-font-name="trebuchet MS bold 12" 
gtk-cursor-theme-name =whiteglass
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_BOTH
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintfull
gtk-xft-rgba=rgb
gtk-auto-mnemonics=1


I have the above in /etc/gtk-2.0/gtkrc

Basically, it sets the gtk-2 theme and font rendering
system wide, if, nothing interferes with them later.
I like Droid Sans Bold 12 also.

djohnston

  • Invité
Re : [Debian 7.0] fresh install with poor man install method
« Réponse #2 le: 19 août 2013 à 21:47:45 »
Anyhow unsure of how to do things next I erased the install and reinstalled anew from a Lxde ISO image taken from here:
http://cdimage.debian.org/debian-cd/7.1.0/i386/iso-cd/

( this iso debian-7.1.0-i386-lxde-CD-1.iso)
If you just wanted a bare minimum LXDE desktop Debian 7 installation, you could have saved some time and aggravation by using this one. You can copy the iso to a USB and boot from it. I suspect the poor man method will work just as well. The sources are already Debian stable. You'd just need to run updates after installation.

My two cents.

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1675
    • Citrotux
Re : [Debian 7.0] fresh install with poor man install method
« Réponse #3 le: 20 août 2013 à 05:34:51 »
Patrick13,

I didn't know about the option 'gtk-auto-mnemonics=1'. I am not sure yet to know what is it's use.

djohnston, I need to start from an official install to work on learning how to create packages. At same time I am re discovering methods I used before but didn't quite remember. Else, I would like to solve the mystery around the font issues. It seems that Gnome environments avoid the problem thanks to the gnome-settings-daemon package, but I don't know what it does. In Archlinux, I have been able to reduce greatly the issue by installing the Ubuntu patched packages provided with the AUR system.

https://wiki.archlinux.org/index.php/Font_Configuration

and finally following the links I might give a try there tomorrow: http://forums.debian.net/viewtopic.php?f=16&t=88545



Good leaders being scarce, following yourself is allowed.

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1675
    • Citrotux
Re : [Debian 7.0] fresh install with poor man install method
« Réponse #4 le: 20 août 2013 à 17:49:28 »
Hi,

Here is a screenshot of the Debian desktop after reconfiguring and seeking for solutions:



Here is how it went.

I have read a wiki at debian-facile.org, but the LMDE packages suggested were not available anymore, so I went to the LDMD chan and got help from someone who directed me straight to the Ubuntu packages. After trials and errors I ended installing 2 packages from the Raring repository, after I checked the versions of the depends could match.

These are libcairo2 and libpixman1-0

http://packages.ubuntu.com/raring/libcairo2

http://packages.ubuntu.com/raring/libpixman-1-0

Then what is also needed is a ~/.fonts.conf

<?xml version="1.0" ?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match target="font">
  <edit name="antialias" mode="assign">
    <bool>true</bool>
  </edit>
</match>
<match target="font">
  <edit name="hinting" mode="assign">
    <bool>true</bool>
  </edit>
</match>
<match target="font">
  <edit name="hintstyle" mode="assign">
    <const>hintmedium</const>
  </edit>
</match>
  <match target="font">
    <edit name="rgba" mode="assign">
      <const>rgb</const>
    </edit>
  </match>
  <match target="font">
    <edit mode="assign" name="lcdfilter">
      <const>lcddefault</const>
    </edit>
  </match>
</fontconfig>

some of the options can be improved (according to what your monitor is), with the help of the Archlinux wiki:
https://wiki.archlinux.org/index.php/Font_Configuration

My ~/.gtkrc-2.0 in Debian:
# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

gtk-theme-name="Clearlooks-Phenix"
gtk-icon-theme-name="Faenza-Mint"
gtk-font-name="Droid Sans 11"
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintmedium"
gtk-xft-rgba="none"
include "/home/my_login/.gtkrc-2.0.mine"

and also ~/.config/gtk-3.0/settings.ini

[Settings]
gtk-theme-name=Clearlooks-Phenix
gtk-icon-theme-name=Faenza-Mint
gtk-font-name=Sans 10
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintmedium
gtk-xft-rgba=rgb

(I did a chattr +i as root on it, because Lxappearance changes it each time I want to reconfigure only the gtkrc-2.0).

and the .Xresources
Xft.lcdfilter:  lcddefault
Xft.dpi: 96.0

(depending on the monitor, and following the Arch wiki, as preceding and not repeating all the configuration already included in the ~/.fonts.conf file).

I am quite satisfied about the result, and will work with it with enough comfort and hopefully pleasure. Some might object that installing some packages from Ubuntu is not good, so I am not sure it could fit in a tips and tricks. What do you think?



Good leaders being scarce, following yourself is allowed.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Re : [Debian 7.0] fresh install with poor man install method
« Réponse #5 le: 20 août 2013 à 20:39:18 »
Patrick13,

I didn't know about the option 'gtk-auto-mnemonics=1'. I am not sure yet to know what is it's use.


Actually there are dozens of settings that one can put in that file, saw
the full list once.     The ones there seem adequate however.   
gtk-auto-mnemonics said it keeps lines off the menu, so it's probably
one extra one, very optional, never had "lines" on the menu.