Auteur Sujet: Networking - wicd and gigolo  (Lu 4935 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Networking - wicd and gigolo
« le: 20 janvier 2013 à 12:04:17 »
I'm trying to set up networking between a couple of computers running OB and using WICD and gigolo.  I've got gigolo installed and Thunar has a network symbol showing - albeit "Windows Network".  WICD is default network manager.  I'm madly googling away, but has anyone tried this combo?  Or is there another simple way of doing this?  Something else I'm reading about is pyneighborhood - an option?

I was thinking that if this doesn't get too messy it might be nice to have in Village_OB - easy home networking.  Or is that an oxymoron!!!
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #1 le: 20 janvier 2013 à 14:14:55 »
Hi,

The network manager and the program gigolo are unrelated. Any network manager can be used to create the connection to the network : wicd, network-manager, command lines such as "dhcpcd", "dhclient", same with an indication of the interface used : "dhcpcd eth0"... or full command lines to attribute a fixed IP to the machine on the local network.

About gigolo, if you want to include it in a box, all you need to do is installing it in the box, no first configuration done : you don't know what the configuration of the local network of the user will be.

Each new connection done in gigolo will be a relation  between the machine from which you operate to another machine somewhere in the same local network, or between this machine behind which you are and severel machines on the local network.

If the user decides to make the hostnames of the "remote machines on the local network" be known from the machine where they operate from, then gigolo will be instructed to connect to:

marguerite 192.168.1.55
philadelphia 192.168.1.49
alleluia 192.168.1.97

...

but you can't know this.
Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #2 le: 20 janvier 2013 à 14:39:11 »
So gigolo needs to be configured to recognise other computers on a network?  So far I've not been able to get two computers sitting next to each other and connected to each other through a router to talk through gigolo!  However I made the connection with an ftp client in seconds.  I've been getting into networking lately but Linux is proving somewhat tricky.  I am a long way from being able to set up network printing!! 
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #3 le: 20 janvier 2013 à 15:09:49 »
gigolo used to work well, but is becoming old. I will do a test between two machines and will tell you if that works here.

In the meanwhile maybe would you want to try xsshfs ? Of course sshfs (or sshfs-fuse is sometimes the package name) needs to be installed.

http://forge.zici.fr/p/xsshfs/downloads


Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #4 le: 20 janvier 2013 à 15:56:10 »
So far I have had success with ssh, and now I am trying sftp through Thunar.  So far that works well except no icon for the connection appears and there seems to be no way to bookmark it.  Got gigolo to connect and it can bookmark but I'm still trying to work out how to get Thunar to recognise SFTP.
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #5 le: 20 janvier 2013 à 16:16:40 »
For the icons you might need to have the same sets of icons on both sides. I have done a full series of screenshots with gigolo to post here I will post them in a few minutes.

And gigolo allows choosing which file manager to use. Same, it will show the screenshots.


Good leaders being scarce, following yourself is allowed.

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #6 le: 20 janvier 2013 à 16:57:22 »
Hi,
Here is a full howto for all: Access remote machines with Gigolo
Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #7 le: 20 janvier 2013 à 17:21:08 »
Thank you - that was too obvious!!!  Change the name of the FM in preferences  :o.  How the heck did I miss that!  All is working now.  I'm going to have to go back through apt-get log to work out what I have installed and throw out the unneeded stuff - got a bit hectic there for a bit.  The other thing to work out is how to launch gigolo in the background but with a tray icon.  It works from terminal but not from autostart.  Maybe .xinitrc?

I have tried sshfs but whatever folder I mount to is inaccessible unless I'm root.   Folders become unknown documents - as root it becomes a folder.  It seems to be an issue with Thunar - still trying to nut that one out.

By the way, nice add to Tips and Tricks.
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Re : Networking - wicd and gigolo
« Réponse #8 le: 20 janvier 2013 à 18:43:39 »
how to launch gigolo in the background but with a tray icon.

Tray icon is available in one of the tabs of the preferences menu.

Have fun!  :D

PS: <mode="OT"> could someone select a few icon themes to install and try on this forum ?</mode> (there are 51 of them available)



Good leaders being scarce, following yourself is allowed.

djohnston

  • Invité
Re : Re : Networking - wicd and gigolo
« Réponse #9 le: 21 janvier 2013 à 00:50:34 »
By the way, nice add to Tips and Tricks.

+1

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #10 le: 21 janvier 2013 à 00:52:13 »
Citation de: melodie
Tray icon is available in one of the tabs of the preferences menu.

I have that checked but it's not working from autostart.  Not working from .xinitrc either.  Maybe a shell script launched from autostart would be the go.  However I am going to look at Spacefm and maybe not have to have gigolo at all.
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #11 le: 21 janvier 2013 à 09:01:33 »
If you install obsession, and add in the ~/.config/autostart file this line:
# Startup applications in the tray with xdg-autostart
xdg-autostart

Then you copy /usr/share/applications/gigolo.desktop to the ~/.config/autostart directory (create it if needed) : here it works.

I tried to add in autostart:
gigolo &
and it worked too, but then the wicd tray applet is missing (I use wicd in Archlinux, and network-manager in Ubuntu because there it does work better in live-cd's).

I still need to test:
xdg-autostart &
I will be right back.

PS: forking xdg-autostart in the background works fine too.


« Modifié: 21 janvier 2013 à 09:03:30 par mélodie »
Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #12 le: 22 janvier 2013 à 00:09:39 »
I have tried just about every permutation I can think of to get gigolo to autostart.  I think I have run out of pages on the net with tips!  Yet once the system is booted gigolo starts in the background and places its icon in the tray just fine.

So far I'm having no luck installing obsession.  I have installed build-essential and libglib2.0-dev - all up 60mb! - but still getting this -
guest@village:~/Downloads/obsession$ make
Compiling lxsession-exit.c
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'dbus-1' found
Package x11 was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11.pc'
to the PKG_CONFIG_PATH environment variable
No package 'x11' found
lxsession-exit.c:21:18: fatal error: glib.h: No such file or directory
compilation terminated.
make: *** [lxsession-exit.o] Error 1
guest@village:~/Downloads/obsession$

Starting to get very messy just to launch one little app!  However gigolo and thunar work well together so regardless of the autostart issue I think gigolo is in to stay.
What can go wrong !!!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1743
    • Citrotux
Re : Networking - wicd and gigolo
« Réponse #13 le: 22 janvier 2013 à 00:48:53 »
Hi,

The files you are missing belong to libgtk2.0-dev. It pulls in 55 more packages then dbus dev is still missing. I'll be right back...

libdbus-1-dev needs to be installed. This one comes alone this time, now the "make" goes till the end.

« Modifié: 22 janvier 2013 à 00:51:05 par mélodie »
Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 391
    • Scorpio_Openbox
Re : Networking - wicd and gigolo
« Réponse #14 le: 22 janvier 2013 à 01:07:00 »
Installed libdbus-1-dev but got same message minus the lines pertaining to Package dbus ...
What can go wrong !!!