Auteur Sujet: xcompmgr desktop effects  (Lu 1961 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
xcompmgr desktop effects
« le: 12 juin 2013 à 11:50:11 »
Most Village Openbox spins have the xcompmgr desktop effects script installed in the ~/.config/openbox/scripts folder.  The commands are written into the root menu and opened via a right-click on the "desktop".  I thought it might be useful to set it up as an "application" so that it could be called from the main applications menu if required.  This would be useful if a panel with the Applications button is being used, like LXDE.

You can download the Desktop_effects.zip here.  This contains the bash script which needs to go into /usr/local/bin, and the .desktop file which goes into /usr/share/applications.  The folder "effects" goes into /usr/share/pixmaps - this has the dialogue and app icons.  The actual xcompmgr script stays in the openbox folder.  I have used the Tango icon scheme in the script but I need to work out some generic icons that will "just work" regardless of what is installed.

Hopefully this will be of some use - screenshot below -

« Modifié: 12 juin 2013 à 14:47:16 par Taco.22 »
What can go wrong !!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1689
    • Citrotux
Re : xcompmgr desktop effects
« Réponse #1 le: 12 juin 2013 à 14:45:24 »
Hello,

The screenshot does not show and when I paste the url into the navigation field I land on a 404 error page.
Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : xcompmgr desktop effects
« Réponse #2 le: 12 juin 2013 à 14:48:43 »
Sorry melodie, I was just editing the first post with a revised upload!  Now has it's own icons in a folder.  Just follow the new instructions.
What can go wrong !!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1689
    • Citrotux
Re : xcompmgr desktop effects
« Réponse #3 le: 13 juin 2013 à 02:28:59 »
This is very cute !
Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : xcompmgr desktop effects
« Réponse #4 le: 13 juin 2013 à 02:59:51 »
Just found an issue - relies on gtkdialog and Debian no longer list that in the repos!!
What can go wrong !!

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : xcompmgr desktop effects
« Réponse #5 le: 13 juin 2013 à 06:56:13 »
Interestingly I installed gtkdialog from http://code.google.com/p/gtkdialog/downloads/list into Openbox with Spacefm (my new one) without a hitch.  The Desktop Effects script works fine.  I'll have to check out what AntiX is up to as gtkdialog is what was behind their antixcc, which is where I lifted the code from! 
What can go wrong !!

djohnston

  • Invité
Re : Re : xcompmgr desktop effects
« Réponse #6 le: 13 juin 2013 à 07:13:52 »
Just found an issue - relies on gtkdialog and Debian no longer list that in the repos!!
AntiX still has it. You may want to download the source to keep locally, too. Add this to sources.list:

# antiX
deb http://www.daveserver.info/antiX/debs testing full main

After adding the repo, do apt-get update. You'll get a missing key error. To enable the repo key, do as root:

keymissing=452F0C20 && gpg --keyserver subkeys.pgp.net --recv-keys $keymissing && gpg --armor --export $keymissing | apt-key add - && apt-get update
It may take a while to get the key. It depends on the server's status. Sometimes I get it right off the bat, other times I have to wait up to a couple of minutes. It failed completely once and I tried again (successfully) the next day. Then apt-get update again to make sure the key took. Install the gtkdialog package, then disable the repo.


Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : xcompmgr desktop effects
« Réponse #7 le: 13 juin 2013 à 07:58:51 »
Neither Scorpio nor Serqet have gtkdialog installed.  To install it do as djohnston suggests above, or to do it manually go to http://www.daveserver.info/antiX/debs/pool/main/g/gtkdialog/, download and install with -
dpkg -i gtkdialog_0.7.20-4.2_i386.deb
Make sure all the bits are in their right places and all will work.  I will add gtkdialog to Scorpio and Serqet at the next upgrade.
What can go wrong !!