Auteur Sujet: Problems with LXDE  (Lu 13747 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : Problems with LXDE
« Réponse #30 le: 06 juin 2013 à 04:48:53 »
For some reason now obsession won't show icons on the logout dialogue box - it used to.  Not sure what I did.  I'm running Openbox with spacefm, greybird gtk theme, meliaeSVG icon theme - otherwise bog-standard VillageBox.  Obsession has it's own icons in /usr/local/share/obsession/images, and I have tried swapping the system icons and theme around.  Even reinstalled obsession.  The .desktop file is set to NoDisplay=true, but changing that makes no difference.  Any ideas?
What can go wrong !!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1680
    • Citrotux
Re : Problems with LXDE
« Réponse #31 le: 06 juin 2013 à 16:16:26 »
guest:x:1000:guest
wheel:x:1001:guest

According to my /etc/group    I'm a member of both groups OK .
That's what I meant.    See above code.    I think that's what is
needed for that to be 100% right.

is "guest" your username ?

wheel is a group which allows a given user to have all rights and permissions.

See here for more information:
http://en.wikipedia.org/wiki/Wheel_%28Unix_term%29

and here if you like little stories:
http://administratosphere.wordpress.com/2007/07/19/the-wheel-group

For some reason now obsession won't show icons on the logout dialogue box - it used to.Any ideas?

I would try to copy the content of the /usr/local/share/obsession/images directly to /usr/share/pixmaps. (directly : not under a sub-directory). My guess is your default icon theme might not have the icons for shutdown and so on, or maybe not with the same file names. If this is the good guess, then /usr/share/pixmaps or /usr/share/icons as a place for the obsession image files could fix it.






Good leaders being scarce, following yourself is allowed.

Hors ligne mimas

  • Général du Roi
  • Modérateur Global
  • Membre Complet
  • *****
  • Messages: 114
  • Jamais content
    • G+
Re : Problems with LXDE
« Réponse #32 le: 06 juin 2013 à 16:53:50 »
Obsession supplies fallback icons in DATA_DIR_PREFIX/share/obsession/images (DATA_DIR_PREFIX is set to /usr/local by default but it can be changed before compilation by 'make configure' command*)

I don't know how the package is built. Obsession-logout takes "system-shutdown", "gnome-session-reboot", "gnome-session-suspend", "gnome-session-hibernate", "gnome-session-switch" and "system-log-out" from stock icons (the theme) before falling back to packaged icons. If there are no icons, it should be a compilation issue, or a path issue or... i don't know.

Did you try to put icons in the /usr/share/obsession/images and /usr/local/share/obsession/images to see if they are displayed?

>  I believe the source code for /usr/bin/lxsession-logout is part of what mimas used to create the obsession package. Very clever, that genius.

Dwarfs standing on the shoulders of giants. :)

* Look at INSTALL.
When any government, or any church for that matter, undertakes to say to its subjects, "This you may not read, this you must not see, this you are forbidden to know," the end result is tyranny and oppression, no matter how holy the motives.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Problems with LXDE
« Réponse #33 le: 06 juin 2013 à 22:38:59 »
is "guest" your username ?

Yes, group guest includes member guest, and group wheel includes
member guest.    The pkla file works with wheel then as the unix group.

The way it is any user can run "su" to get root privileges.    That's OK too.
Or restrict "su" to the wheel group, but I don't need that today.

thx

patrick

djohnston

  • Invité
Re : Re : Problems with LXDE
« Réponse #34 le: 06 juin 2013 à 23:38:33 »
Yes, group guest includes member guest, and group wheel includes member guest.

Patrick,

I am struggling to understand how your installation is set up. Are you talking about a live CD session or a full installation to hard drive? If this is an installation, you should not have to use the guest account. Create a new user account for yourself with a unique name (not root, guest, wheel, admin). Just like the group wheel, guest is a system reserved account name. Guest is meant to have extremely limited privileges. Under no circumstances should the guest account be a member of the group wheel. By doing so, you have given the guest account, which is meant to have limited privileges, full system access by being a member of the group wheel.


Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : Problems with LXDE
« Réponse #35 le: 07 juin 2013 à 01:10:34 »
re: obsession

I just did a launch in terminal and got -
/usr/share/shearwater/gtk-2.0/gtkrc:339: Unable to locate image file in pixmap_path: "panel-bg-dark.png"
The icons are at /usr/local/share/obsession/images so I'll try relocating them to /usr/share/pixmaps and see how it goes.
What can go wrong !!

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Re : Re : Problems with LXDE
« Réponse #36 le: 07 juin 2013 à 02:05:14 »
I am struggling to understand how your installation is set up. Are you talking about a live CD session or a full installation to hard drive? If this is an installation, you should not have to use the guest account.

When I installed this to the flash drive, full install, I made myself a user
in group "guest" user name "guest"  group number 1000.    I could setup
a different group for each user, like group"guest1"  user name "guest1"
group number 2000  and so forth.    Setting up normal users is very flexible.

Being in the Wheel group does not give user "guest" root power, already
tried it, had to enter the root password for that.    So the root password is
req'd for everyone in group wheel to run root programs as usual.     Without
the root password I can't do anything, if in the wheel group or not.

So it should be safe to use the wheel group.    Additional config to wheel
would be req'd to give everybody in there root powers without the root
password,  make it a group equal to root:root somehow.

thanks for the response.

patrick
« Modifié: 07 juin 2013 à 02:07:02 par patrick013 »

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1680
    • Citrotux
Re : Problems with LXDE
« Réponse #37 le: 07 juin 2013 à 02:45:03 »
I know this because I lost consolekit access when I removed LightDM and used ~/.xinitrc to startx on user login. I could logout normally, but not shutdown or reboot. I added exec ck-launch-session jwm to the .xinitrc, but still wasn't working. After about 3 hours of web searching and trying different approaches to the problem, I threw in the towel and reinstalled LightDM.

For the record, AntiX uses Slim display manager instead of LightDM.

Then try again but with:
exec dbus-launch ck-launch-session jwm
in your ~/.xinitrc

I had to do it this way in Archlinux. (And you need to check if you have seats in your session, as simple user "ck-list-sessions".)

But Archlinux has moved so fast to systemd…  ConsoleKit isn't used anymore in the current Archlinux.




« Modifié: 07 juin 2013 à 02:52:03 par mélodie »
Good leaders being scarce, following yourself is allowed.

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1680
    • Citrotux
Re : Re : Problems with LXDE
« Réponse #38 le: 07 juin 2013 à 02:48:06 »
re: obsession

I just did a launch in terminal and got -
/usr/share/shearwater/gtk-2.0/gtkrc:339: Unable to locate image file in pixmap_path: "panel-bg-dark.png"
The icons are at /usr/local/share/obsession/images so I'll try relocating them to /usr/share/pixmaps and see how it goes.

Yes, and if that does not work (you might need to logout/login in between? Not sure about that) you can try /usr/share/icons and also what mimas suggested above:
Citer
Did you try to put icons in the /usr/share/obsession/images and /usr/local/share/obsession/images to see if they are displayed?

Good leaders being scarce, following yourself is allowed.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Problems with LXDE
« Réponse #39 le: 07 juin 2013 à 02:52:58 »
guest:x:1000:guest
wheel:x:1001:
polkituser:x:1002:guest

@dj

The obsession logout works also with the polkituser group setup in /etc/group.
Reply 32 this thread has two links from Melodie about the "archaic"
wheel group.

Just FYI

Patrick

djohnston

  • Invité
Re : Re : Problems with LXDE
« Réponse #40 le: 07 juin 2013 à 05:33:11 »
@dj

The obsession logout works also with the polkituser group setup in /etc/group. Reply 32 this thread has two links from Melodie about the "archaic" wheel group.
I think you mean reply #31. In any case, the "archaic" link Mel posted goes on to say this:

Citer
The wheel group is, perhaps, not widely used today, or is seen as “archaic” and irrelevant. Nothing could be further from the truth.
The article goes on to say,

Citer
Is it any wonder that GNU/Linux systems don’t enable the wheel group by default?
You are right, though. The wheel group is meant to limit the users who can su to the root account, as explained on one of Slackbook pages:

Citer
The wheel group is a legacy from UNIX. When a server had to be maintained at a higher level than the day-to-day system administrator, root rights were often required. The 'wheel' group was used to create a pool of user accounts that were allowed to get that level of access to the server. If you weren't in the 'wheel' group, you were denied access to root.
Coming from a UNIX background before ever seeing Linux, I was looking at the wheel group in that context. I was looking at it the wrong way, though. Thanks for setting me straight. However, and this is where it gets a bit sticky, you should be able to logout/shutdown/reboot as a normal user in Debian, even as the user guest. Here's a guy who was trying to disable that feature in wheezy:

Citer
I installed 6.0.something wheezy, and i want to create a guest user without the privilege to shutdown/reboot my computer.
So, now I am unsure as to where your original problem with logging out originated from. I am not a member of the group wheel or sudo or polkituser, yet I am able to logout/shutdown/reboot as a normal user. As a matter of fact, the groups wheel and polkituser do not even exist in my installation(s).

Of course, you are free to setup your installation however you see fit. I should have no say in what you do unless it affects me in some way. I just don't understand why you are using the guest account to login as a regular user. It seems foreign to me.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Re : Re : Problems with LXDE
« Réponse #41 le: 07 juin 2013 à 06:55:00 »
I am not a member of the group wheel or sudo or polkituser, yet I am able to logout/shutdown/reboot as a normal user. As a matter of fact, the groups wheel and polkituser do not even exist in my installation(s).
My LXDE came straight from Debian, Scorpio from LinuxVillage.
You must not have "root" programs open when shutting down or
have sudo in the  command line.     Beats me ?     Some library
nobody else has ?     Some Polkit option set ?

I just don't understand why you are using the guest account to login as a regular user. It seems foreign to me.
In the full installs I do :

guest:x:1000:guest          (the normal user I login with)
or
users:x:100:patrick          (my user if in the users group)

are both the same in the sense that neither interfere with
system or root or admin groups and are seen by the system
as normal users in normel groups.    I could put many users
in group 1000 with any name as normal non-root users.

Have a good one.

Patrick

djohnston

  • Invité
Re : Re : Re : Re : Problems with LXDE
« Réponse #42 le: 07 juin 2013 à 14:06:44 »
My LXDE came straight from Debian, Scorpio from LinuxVillage. You must not have "root" programs open when shutting down or have sudo in the  command line.     Beats me ?     Some library nobody else has ?     Some Polkit option set ?
Okay, I took the plunge. I installed Scorpio from the Scorpio_2013-2 iso image. Is that the one you used? On installation, I added a normal user named "darrel". On first boot after installation, I opened a terminal, and as root did: apt-get update, then apt-get dist-upgrade. After the upgrade, I installed Synaptic, then rebooted.

After rebooting, I started Synaptic and installed the lxde desktop. I did not install lxde (metapackage) or task-lxde-desktop (metapackage). I selected the lxde-common package and accepted all the recommended dependencies. Whatever other LXDE packages were still unmarked I selected for installation, except lxmusic and lxpolkit. Then I closed Synaptic and logged out. LXDE is now the default Xsession. At the LightDM login window, I can select Default Xsession or LXDE and I will get the same result. I logged in as user "darrel". After about a minute, I clicked the red logout button in the far right corner of the lxpanel. This brought up the lxde-session window and I selected Reboot. The machine rebooted.

I logged in as user darrel again and opened a terminal. After su'ing to root, I created the user "guest".

root@Scorpio:~# useradd -d /home/guest -m guest

Notice I did not specify any groups to add the user guest to. I only specified the home directory and the switch to create the directory. Next, I set a password for user guest.

root@Scorpio:~# passwd guest
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
root@Scorpio:~#


After ending root's terminal session, I logged out and logged in as user guest. After about a minute, I clicked the red logout button in the far right corner of the lxpanel. This brought up the lxde-session window and I selected Reboot. The machine rebooted.

Here are the groups user guest belongs to:

guest:x:1001:

Yet, user guest is able to logout, reboot and shutdown the machine. Here are the groups user darrel belongs to:

dialout:x:20:darrel
cdrom:x:24:darrel
floppy:x:25:darrel
audio:x:29:darrel
video:x:44:darrel
plugdev:x:46:darrel
netdev:x:113:darrel
vboxsf:x:119:darrel
darrel:x:1000:

The vboxsf group is for the VBox shared folder service. User darrel is not a member of sudo, polkituser or wheel. As a matter of fact, there is no polkituser or wheel group.

root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:darrel
fax:x:21:
voice:x:22:
cdrom:x:24:darrel
floppy:x:25:darrel
tape:x:26:
sudo:x:27:
audio:x:29:darrel
dip:x:30:
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:darrel
sasl:x:45:
plugdev:x:46:darrel
staff:x:50:
games:x:60:
users:x:100:
libuuid:x:101:
crontab:x:102:
avahi-autoipd:x:103:
scanner:x:104:saned
messagebus:x:105:
colord:x:106:
lpadmin:x:107:
ssl-cert:x:108:
Debian-exim:x:109:
mlocate:x:110:
ssh:x:111:
netdev:x:113:darrel
bluetooth:x:114:
saned:x:115:
fuse:x:116:
lightdm:x:117:
utempter:x:118:
vboxsf:x:119:darrel
debian-xfs:x:121:
ntp:x:120:
nogroup:x:65534:
darrel:x:1000:
guest:x:1001:

Again, this is an LXDE installation to Taco.22's Scorpio 2013.2 remaster. I employed no trickery. There are no "magic" groups. Just a standard straightforward install, with the exception of manually adding user guest.

Also notice that user darrel's UID (user ID) is 1000 and that user guest's UID is 1001. If I create another user, the default UID will be 1002, unless I specify a different UID when creating the new user.

Without knowing more about how you did the installation and what steps you took to create multiple guest users, I could only guess as to what caused your original problem with being able to log out. You say that a program is "running as root" when you logout. If by that you mean that there is an application that you manually started as user root, then I fail to see why you would want to leave it running during a logout, reboot or shutdown. If you mean that there are system services that were started by user root, that is normal and is part of the sysvinit bootup process.


djohnston

  • Invité
Re : Re : Problems with LXDE
« Réponse #43 le: 07 juin 2013 à 14:12:06 »
Then try again but with:
exec dbus-launch ck-launch-session jwm
in your ~/.xinitrc

Pretty sure I already tried that, but I'll uninstall LightDM and try it again. I'm pretty sure the authorization is coming from PAM rules that LightDM (and probably other display managers) install. Just haven't narrowed it down yet. This may all be moot anyway, as I intend to use mimas's obsession. So, I'm off to try that.


Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1680
    • Citrotux
Re : Re : Re : Problems with LXDE
« Réponse #44 le: 07 juin 2013 à 15:35:03 »
Pretty sure I already tried that, but I'll uninstall LightDM and try it again. I'm pretty sure the authorization is coming from PAM rules that LightDM (and probably other display managers) install. Just haven't narrowed it down yet. This may all be moot anyway, as I intend to use mimas's obsession. So, I'm off to try that.

Can you post the /etc/pam.d/lighdm file ? We could try to study it's content. I have not enough knowledge about PAM yet and this would be an opportunity to have a close look on this specific issue.





Good leaders being scarce, following yourself is allowed.