Auteur Sujet: Problems with LXDE  (Lu 14109 fois)

0 Membres et 2 Invités sur ce sujet

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : Problems with LXDE
« Réponse #15 le: 05 juin 2013 à 04:43:17 »
Thanks for the link - I had one or two that hit a dead end.  Your're right about the panel logout command - right click the panel and hit Panel Settings which brings up PanelPreferences(?!?), go to Advanced and fill in the appropriate Logout Command.  Nice and simple.  I just went an extra step and added a Logout button on the panel which LXDE doesn't supply.

By the way, the VillageBox menu.xml and rc.xml settings still apply, so the keybinding of W-x still shuts the machine down, even if the Openbox root menu is not accessible on the "desktop".   
What can go wrong !!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1682
    • Citrotux
Re : Problems with LXDE
« Réponse #16 le: 05 juin 2013 à 04:59:33 »
Some time ago I put most of the stuff here: http://meets.free.fr/Downloads. (Kind of winter cleaning).


Good leaders being scarce, following yourself is allowed.

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : Problems with LXDE
« Réponse #17 le: 05 juin 2013 à 05:16:42 »
That was one of my dead-end links.
What can go wrong !!

djohnston

  • Invité
Re : Problems with LXDE
« Réponse #18 le: 05 juin 2013 à 09:10:01 »
Could I see the entire content of your /etc/group file ? I wonder which process in Debian sets up the groups for the first user created at install time?

The JWM installation is starting to shape up and uses 47.3 MB at startup. The following is from that installation:

darrel@VSLV:~$ cat /etc/group
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:darrel
fax:x:21:
voice:x:22:
cdrom:x:24:darrel
floppy:x:25:darrel
tape:x:26:
sudo:x:27:
audio:x:29:darrel
dip:x:30:
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:darrel
sasl:x:45:
plugdev:x:46:darrel
staff:x:50:
games:x:60:
users:x:100:
libuuid:x:101:
crontab:x:102:
vboxsf:x:103:darrel
fuse:x:104:
scanner:x:105:saned
messagebus:x:106:
colord:x:107:
bluetooth:x:108:
netdev:x:109:darrel
Debian-exim:x:110:
mlocate:x:111:
ssh:x:112:
avahi:x:113:
lpadmin:x:114:
utempter:x:115:
saned:x:117:
lightdm:x:116:
ntp:x:118:
nogroup:x:65534:
darrel:x:1000:
darrel@VSLV:~$


djohnston

  • Invité
Re : Problems with LXDE
« Réponse #19 le: 05 juin 2013 à 10:04:52 »
Rumaging around in my box of spare bits I found the debian version of obsession that mimas had posted somewhere - I can't find where so just in case I have it here for download.

Pre-compiled.  :)  I like it!

Your're right about the panel logout command - right click the panel and hit Panel Settings which brings up PanelPreferences(?!?), go to Advanced and fill in the appropriate Logout Command.  Nice and simple.  I just went an extra step and added a Logout button on the panel which LXDE doesn't supply.

There is another way, but it isn't provided by installing just lxpanel. The shell script /usr/bin/lxde-logout and the desktop file /usr/share/applications/lxde-logout.desktop are provided by the Debian lxde-common package. If that one is installed along with lxpanel, you can create a launcher on the panel. Right-click the lxpanel, select Panel Settings and it shows a window titled "Panel Preferences", just like you said. Instead of selecting the Advanced tab, select the Panel Applets tab. Scroll to the bottom, select "Application Launch Bar" and add it to the panel. Close the window, then right-click the Application Launch Bar you just added to the panel. Select "'Application Launch Bar' Settings" and the window will pop up. You can browse the Available Applications in the right pane and add them to the left pane, thereby adding the application to the App Launch Bar on the panel. Confused yet?

You can add the Logout app, except that it doesn't show in the right pane unless you also installed the lxde-common package. Even then, it doesn't show. Here's why. The desktop file in /usr/share/applications contains the entry:

NoDisplay=true

Change that to:

NoDisplay=false
or
#NoDisplay=true

Add a Categories= line, for example:

Categories=System;

and it will show up in the System section where you can add it to the Application Launch Bar section of the lxpanel. Oh, and you can have multiple launch bars. When you click the Logout icon in the newly added Application Launch bar on the lxpanel, it will run the shell script /usr/bin/lxde-logout, which in turn calls the compiled executable /usr/bin/lxsession-logout. The executable displays the standard LXDE Shutdown/Reboot/Hibernate/Logout etc. menu.

Come to think of it, the way you did it is a helluva lot easier!  ;)

EDIT: I believe the source code for /usr/bin/lxsession-logout is part of what mimas used to create the obsession package. Very clever, that genius.  ;)
« Modifié: 05 juin 2013 à 10:10:08 par djohnston »

Hors ligne Taco.22

  • Membre Senior
  • ****
  • Messages: 367
    • Scorpio_Openbox
Re : Problems with LXDE
« Réponse #20 le: 05 juin 2013 à 11:38:04 »
Citation de: djohnston
Come to think of it, the way you did it is a helluva lot easier!  ;)

Yep, got it in one!  What I did is set up Openbox with lxpanel - stayed well away from LXDE itself.  So under the bonnet it is still Openbox running everything. I'm using Spacefm to create the "desktop" experience, but even though the Openbox right-click root menu is disabled OB's autostart, menu.xml and rc.xml are still running the show.  That and a bit of tweaking of the panel and gtk theme.  Adding the Logout button to the panel was straightforward - used "NoDisplay=true" so that it doesn't show in the main menu.  Also did that with Remastersys' Live Installer - not sure if that needs to be just laying about!
What can go wrong !!

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1682
    • Citrotux
Re : Problems with LXDE
« Réponse #21 le: 05 juin 2013 à 13:17:07 »
Pre-compiled.  :)  I like it!

Thanks. ;)
* mélodie pre compiles here and then…

Citer
EDIT: I believe the source code for /usr/bin/lxsession-logout is part of what mimas used to create the obsession package. Very clever, that genius.  ;)

He said so, code borrowed from LXDE. He is very clever at coding!

The JWM installation is starting to shape up and uses 47.3 MB at startup. The following is from that installation:

darrel@VSLV:~$ cat /etc/group
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:darrel
fax:x:21:
voice:x:22:
cdrom:x:24:darrel
floppy:x:25:darrel
tape:x:26:
sudo:x:27:
audio:x:29:darrel
dip:x:30:
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:darrel
sasl:x:45:
plugdev:x:46:darrel
staff:x:50:
games:x:60:
users:x:100:
libuuid:x:101:
crontab:x:102:
vboxsf:x:103:darrel
fuse:x:104:
scanner:x:105:saned
messagebus:x:106:
colord:x:107:
bluetooth:x:108:
netdev:x:109:darrel
Debian-exim:x:110:
mlocate:x:111:
ssh:x:112:
avahi:x:113:
lpadmin:x:114:
utempter:x:115:
saned:x:117:
lightdm:x:116:
ntp:x:118:
nogroup:x:65534:
darrel:x:1000:
darrel@VSLV:~$



So this is antiX ? You see a "sudo" group in the list: use "sudo" in a 55-myconf.pkla under /etc/polkit-1/… as previously presented. Then the user just has to add himself to the sudo group if he is not in yet.
Good leaders being scarce, following yourself is allowed.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Problems with LXDE
« Réponse #22 le: 05 juin 2013 à 23:42:46 »
What an improvement.     Working with Scorpio.

Installed obsession, fixed the pkla file, and Scorpio
now shutdown's with root windows open without
asking for the root password with both obsession and
pygtk-shutdown.

Contemplating changing  /home/user-oldgroup to
/home/user-wheel for my /home/user directory and files
but no problems yet with that.

Thanks a bunch Melodie,

Patrick      :D

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1682
    • Citrotux
Re : Problems with LXDE
« Réponse #23 le: 06 juin 2013 à 00:00:55 »
Hi Patrick,

Welcome.

Changing the ownership of files or directories is not what I was talking about. To add a user to a group the command as root is "gpasswd -a <user> <group>".

This is what I was talking about.

Good leaders being scarce, following yourself is allowed.

djohnston

  • Invité
Re : Problems with LXDE
« Réponse #24 le: 06 juin 2013 à 00:06:19 »
So this is antiX ? You see a "sudo" group in the list: use "sudo" in a 55-myconf.pkla under /etc/polkit-1/… as previously presented. Then the user just has to add himself to the sudo group if he is not in yet.

No, not AntiX. Straight Debian. I believe the sudo group is added for Remastersys's live CD session. But, you still don't need to be a member of the sudo group to logout/restart/shutdown. It's just not necessary.

There's something added by the installation of LightDM, (which is included in the standard Debian installation), that enables the consolekit access for a regular user. I just haven't discovered what it is, yet. I know this because I lost consolekit access when I removed LightDM and used ~/.xinitrc to startx on user login. I could logout normally, but not shutdown or reboot. I added exec ck-launch-session jwm to the .xinitrc, but still wasn't working. After about 3 hours of web searching and trying different approaches to the problem, I threw in the towel and reinstalled LightDM.

For the record, AntiX uses Slim display manager instead of LightDM.

djohnston

  • Invité
Re : Problems with LXDE
« Réponse #25 le: 06 juin 2013 à 00:11:36 »
Contemplating changing  /home/user-oldgroup to /home/user-wheel for my /home/user directory and files
but no problems yet with that.

Patrick, that's not a good idea. The /home/user-oldgroup files and directories should belong to user-oldgroup, or to another normal user. But, not to wheel. Wheel is a reserved group with elevated system privileges and should not be the owner of any files in the /home directory structure.


Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1682
    • Citrotux
Re : Problems with LXDE
« Réponse #26 le: 06 juin 2013 à 00:20:51 »
Patrick, that's not a good idea. The /home/user-oldgroup files and directories should belong to user-oldgroup, or to another normal user. But, not to wheel. Wheel is a reserved group with elevated system privileges and should not be the owner of any files in the /home directory structure.

Exactly.

Generally speaking the ownership configured normally by the system for the files and the directories should never be changed.

In Archlinux, the files which belong to the user used to belong to "user:group" which was for example "melodie:users". Later, it became as in Ubuntu : "melodie:melodie" and since it has been "melodie:users" again. In Slackware and derived, it's also "user:users".

If a file or directory has the wrong permission, because, let's say, you created it as root, then you will need to change the ownnership in a way which will allow you to manage it as user : the ones in your home, of course!



Good leaders being scarce, following yourself is allowed.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Problems with LXDE
« Réponse #27 le: 06 juin 2013 à 00:58:09 »

Changing the ownership of files or directories is not what I was talking about. To add a user to a group the command as root is "gpasswd -a <user> <group>".

This is what I was talking about.

That command helps.    I'm able to get into the users group and the wheel
group at the same time.    gnome-user-settings would only do one or the other.

thx

patrick

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1682
    • Citrotux
Re : Problems with LXDE
« Réponse #28 le: 06 juin 2013 à 01:08:41 »
<user> stands for your username and <group> for your group. Usually you are already member of the group users : it's the default and minimum in all distros, AFAIK.

And it allows adding your user to one group at same time only. (Sorry but " I'm able to get into the users group and the wheel group at the same time. " does not make sense to me... )

Good leaders being scarce, following yourself is allowed.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : Problems with LXDE
« Réponse #29 le: 06 juin 2013 à 01:27:05 »
And it allows adding your user to one group at same time only. (Sorry but " I'm able to get into the users group and the wheel group at the same time. " does not make sense to me... )
guest:x:1000:guest
wheel:x:1001:guest

According to my /etc/group    I'm a member of both groups OK .
That's what I meant.    See above code.    I think that's what is
needed for that to be 100% right.

thx

patrick