Auteur Sujet: OpenSuse failure  (Lu 1929 fois)

0 Membres et 1 Invité sur ce sujet

djohnston

  • Invité
OpenSuse failure
« le: 18 mars 2013 à 00:17:28 »
I try to keep an open mind. This includes trying distros I may not like. I ran Mageia2 for about six months in a test installation. It performed well enough, except that the package updater, which had to be run from the Mageia Control Center, never worked. I had to update packages by starting the package manager, updating the sources, then selecting system update. So far, Mageia3's performance has been flawless. I cannot fault any portion of it, although it is still a beta release. There was a period where the kernel could not be updated properly, but the developers corrected that. And, during that time, a kernel update was never offered because of the existing problem.

OpenSuse released version 12.3 a few days ago. A couple of days ago, I saw an article online that declared the e17 desktop environment could be installed instead of the usual KDE or Gnome or XFCE. The installation iso is a DVD-sized 4GB. I did not want to download that large of a file just to install what is considered a "minimalist" desktop. Seeing there is a netinstall iso of about 270MB, I downloaded that, then started the installation in VirtualBox, where most of my testing is done.

The installer is a nice GUI which runs, pretty much, on autopilot. I did not like the proposed disk partition layout and altered it so suit my own needs. When the desktop selection portion came up, e17 was not on the list of alternate desktops. I had to settle for LXDE. The netinstall took about 40 minutes to download and install the packages. A reboot was done automatically at the end of the installation. For some reason, the iso was not automatically unmounted and ejected as is done so often with other distros.

After manually removing the attached iso, I logged in to the new LXDE desktop. The OpenSuse installation continued, running its final steps, downloading and installing packages and sources from their repositories. Once that had finished, I decided to install the e17 desktop. I started Yast software manager, selected the packages, and away I did not go. "Could not contact server" was the error message given. What the ...? It was contacted not 2 minutes ago. ifconfig showed NO eth0 device and a ping to google.com failed. I rebooted. Hmmm. The eth0 device magically reappeared and I, once again, had a network connection. Strike one.

I started Yast software manager again and selected what few e17 packages there were to install. Most were themes from Agust. The Yast window immediately disappeared. Had it crashed? I loaded it again to see if the packages were installed, They were, indeed, installed. I closed Yast, logged out of LXDE and into the e17 desktop. Immediately, I noticed a big exclamation mark as an icon in the bottom "shelf" (what others refer to as a panel). So, I selected the settings for it and discovered it was a non-functioning connection manager. The error message indicated that I needed to have econnman installed for it to work.

I dug around in the menus and discovered that I could not launch Yast as root from the menus. Okay, maybe a desktop file needed to be edited. That was tolerable. I logged out of e17 and logged into the LXDE desktop. After starting Yast, I could not find econnman. It's not offered in the repos, although a launcher for it was installed in a desktop panel. Strike two.

I closed Yast software manager and opened the Yast system control center. Finding the portion to edit /etc/sysconfig, I browsed to the sections for default window manager and desktop environment. e17 was not listed for either option. Strike three.

But, I try to keep an open mind. Remember? I opened a terminal, su'ed to root and tried to update the locate database. Another error message. This one a bit cryptic. Once again, I opened Yast software manager and searched for a locate package. No mlocate package, no slocate package, just a cron job that would run find every 24 hours. I installed that. The Yast software manager window disappeared again. Not a good indication. I opened Yast one more time to verify that the package had really been installed. Opened a terminal again, su'ed to root, and:

darrel@linux-hr9c:~> su -
Password:
linux-hr9c:~ # updatedb
/usr/bin/find: `/var/run/user/1000/gvfs': Permission denied

Strike four. Now, you're outta here! OpenSuse is not for me. Is it for you?

Hors ligne melodie

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 1771
    • Citrotux
Re : OpenSuse failure
« Réponse #1 le: 18 mars 2013 à 00:35:09 »
It's not for me. I tried to boot to a live when I had a PIII with 384 MB ram and a 933 Mhz processor, it was so slow I never had a chance to get to a console or any package manager. So I gave up once for all. I like testing distros, I don't like to endure such a pain. Your feedback just confirms I have no reason to try again, even if I had the idea to do so!





Good leaders being scarce, following yourself is allowed.

konaexpress

  • Invité
Re : OpenSuse failure
« Réponse #2 le: 18 mars 2013 à 01:44:32 »
Not a big fan of Suse myself but some people love it.

Hors ligne patrick013

  • Membre Senior
  • ****
  • Messages: 252
Re : OpenSuse failure
« Réponse #3 le: 18 mars 2013 à 02:06:29 »
Suse's OK.    I used to be able to install it.    The 4 GB disk has
a whole repo on it.    Mine was an XFCE, and ran well.

They had some little repos running to get most of the codecs and
some other programs.   

djohnston

  • Invité
Re : OpenSuse failure
« Réponse #4 le: 18 mars 2013 à 04:59:37 »
Hey, Patrick, don't get me wrong. I was first "weaned" on SuSe 9.1, back when it was spelled that way. Later upgraded to 9.2. Both were solid, and I was dual-booting between WindowsXP and SuSe. Suzy was very good, back then. Easily on par with Mandrake. When 9.3 came out, it took a nosedive and went downhill for years. I'm told it's good on servers. But, the only thing I've ever seen run on servers has been Debian, RHEL and CentOS. That, and FreeBSD.

Suse was once very good. At least I thought so. Not so much any more.